Blog

Postado em em 18 de abril de 2022

Funções do Excel: veja as principais de 13 categorias

Quantas e quais das principais funções do Excel você já ouviu falar? Podemos te garantir que existem muitas e muitas. 

E quanto mais você conhecer, melhor pode ficar a sua rotina, não tenha dúvidas!

Afinal, essas ferramentas conseguem fazer todo o tipo de atividade, desde uma soma simples, até mesmo, o cálculo de uma equação complexa. 

Tantas vantagens acabam sendo um braço direito para o seu dia a dia, não é mesmo? 

Então, continue a leitura e saiba quais são as funções do Excel conhecidas como protagonistas!

Aproveite as dicas!

Quer aprender a mexer no Excel ainda hoje? Conheça o Curso Completo Online e com certificação de Excel da Hashtag Treinamentos!

Afinal, quais são as principais funções do Excel? 

Descubra como elas podem te ajudar na rotina do trabalho, dos estudos ou das organizações pessoais.

Existem fórmulas para todos os gostos e necessidades. 

1. Lógicas

As funções lógicas são as que adaptam operações lógicas para o ambiente do Excel.

Geralmente, lidam com proposições e analisam para retornar um valor.

Função E, Função FALSO, Função SE

A função E é muito importante. Ela retorna um valor verdadeiro quando as duas proposições (ou as duas células comparadas) são verdadeiras. Ou seja, se você tem duas células, elas precisam ser concomitantemente verdadeiras.

A função FALSO simplesmente retorna o valor FALSO. É muito útil em complemento com a função que veremos a seguir.

A função SE é uma das mais fundamentais nas operações do Excel. Ela estabelece uma condição: se algo acontecer, faça isso; se não, faça outra coisa.

Exemplo: se uma célula for maior que 10, mude o valor de outra célula para verdadeiro; caso contrário, mude para falso.

Função SEERRO, Função SENÃODISP, Função SES

A função SEERRO tem a função de identificar um erro em um dado cálculo e preparar uma ação caso isso ocorra.

A função SENÃODISP retorna um dado valor passado como parâmetro se o Excel encontrar um erro #N/D.

Já a função SES é uma melhoria da função SE. Permite testar várias condições ao mesmo tempo, no mesmo comando. Caso a função não existisse, seria preciso usar vários SEs aninhados. 

Função NÃO, Função OU, Função PARÂMETRO

A função NÃO retorna o valor lógico contrário ao existente em uma célula. Se houver verdadeiro, retorna falso; e vice-versa. 

A função OU é tão importante quanto à função E. Retorna verdadeiro se você tiver pelo menos uma das proposições como verdadeira. 

A função parâmetro serve para mapear dois conjuntos de valores. É possível criar uma relação entre um conjunto e outro, com atribuição direta de valores para marcar esse conjunto.

Função VERDADEIRO, Função XOR.

A função VERDADEIRO retorna o valor correspondente ao nome da função.

A função XOR retorna verdadeiro somente quando as duas proposições analisadas apresentarem o mesmo valor lógico.

2. Pesquisa e referência

Função ENDEREÇO, Função ÁREAS, Função ESCOLHER

A função ENDEREÇO retorna o endereço correspondente a uma célula. Ao passo que a função ÁREAS retorna o número de áreas que existem em uma dada referência.

A função ESCOLHER serve para selecionar valores entre alguns dados passados como parâmetro.

Função COLUNA, Função COLS, Função FILTRO, Função FÓRMULATEXTO

A função COLUNA retorna o número de uma coluna para uma referência passada como parâmetro. A função COLS, por sua vez, apresenta o número de colunas.

A função FILTRO serve para filtrar dados com base nas informações passadas. Já com a função FÓRMULATEXTO, você consegue em formato de texto a fórmula de uma referência.

Função INFODADOSTABELADINÂMICA, Função PROCH, Função HIPERLINK, Função ÍNDICE

A Função INFODADOSTABELADINÂMICA retorna dados de uma tabela dinâmica. A função PROCH serve para procurar informações e retornar de acordo com o que foi especificado.

A função HIPERLINK faz um link com algum site ou página na web. A função INDICE estabelece um índice para uma referência ou matriz.

3. Banco de dados

Função BDMÉDIA, Função BDCONTAR, Função BDCONTARA, Função BDEXTRAIR

A função BDMÉDIA devolve a média de valores em conjunto. A função BDCONTAR soma os valores que atendem a alguma característica especificada (o usuário determina quais são as colunas que deseja contar). 

A função BDCONTARA conta células que não estão vazias. A função BDEXTRAIR serve para buscar um valor único acerca de alguma coluna do banco.

Função BDMÁX, Função BDMÍN, Função BDMULTIPL, Função BDEST

BDMÁX e BDMIN retornam os máximos e mínimos de um dado conjunto. BDMULTIPL multiplica os valores analisados. A função BDEST cuida do desvio padrão.

Função BDDESVPA, Função BDSOMA, Função BDVAREST

BDDESVPA calcula o desvio padrão de dados selecionados. BDSOMA soma os valores analisados. E a variância pode ser obtida com BDVAREST.

4. De informação

Na categoria de informação, a função CEL é uma das mais complexas e retorna metadados acerca de uma célula (formatação, valores, localização).

TIPOERRO devolve o número que registrou o erro da célula. A função INFORMAÇÃO apresenta alguns dados sobre o sistema operacional.

Chegamos ao conjunto de funções “É” do Excel. Elas são bem simples e geralmente retornam um valor lógico respondendo à pergunta do nome. São complementos da função SE.

ÉCÉL.VAZIA retorna se uma célula é vazia; ÉERRO retorna se é um erro; ÉPAR retorna se o número daquela célula é par; ÉFÓRMULA retorna verdadeiro quando há uma fórmula em um dado campo.

ÉLÓGICO retorna verdadeiro se um valor é lógico. Se você obtém um erro #N/D, a função É.NÃO.DISP retorna verdadeiro.

É.NÃO.TEXTO devolva verdadeiro se um elemento não é um texto.

5. Condicional

A função condicional é utilizada para obter dois tipos de resultado, verdadeiro ou falso de acordo com a condição que foi colocada. 

Isso é fundamental para as mais diversas áreas profissionais. 

Com essa opção, não será preciso verificar linha por linha da planilha para verificar o resultado de forma manual, isso fica tudo automático, pois a verificação pode ser feita em cada uma das linhas com a fórmula.

Um exemplo: vamos supor que você tenha uma planilha para gestão de estoque, ok? 

Nela, dá para atualizar a quantidade de produtos diariamente e, quando alguns itens estiverem próximos de acabar, podemos colocar um texto informando que o estoque está baixo.

Assim, fica mais fácil identificar a necessidade de uma nova compra de produtos quanto antes. 

Fórmula:

=SE(A1<50;”Estoque Baixo”;”Estoque OK”)

Neste caso vamos considerar que na coluna A temos os valores de estoque dos seus produtos, então se essa quantidade for menor ou igual a 50 é um número baixo para essa operação.

Dessa forma já vamos mostrar ao usuário que o estoque está baixo e que precisa ser reposto!

6. Procura

Mais uma das principais funções do Excel é a de procura. 

Como o próprio nome diz, ela serve para você vasculhar informações, sejam elas em forma de textos ou de números, dentro da sua planilha do Excel

Então, dentro do parênteses, é necessário colocar o intervalo de linhas ou colunas a serem analisadas. 

Um ponto interessante que muita gente desconhece é que dá para, também, procurar dois dados ao mesmo tempo com a função procura. 

Fórmula:

=PROCV

No vídeo abaixo, você confere um passo a passo para procurar duas informações de uma só vez: 

7. Data e Hora

A terceira função, na verdade, agrega dois componentes: data e hora. 

É possível colocar os dados atuais, ou seja, o mês vigente e, exatamente, as horas e os minutos de agora. 

Esses tipos de dados podem fazer parte de um relatório para a diretoria da empresa ou, ainda, do controle de registro de ponto dos funcionários. 

Fórmulas:

=HOJE ()

=HORA(AGORA())

8. Financeiro

O controle das despesas e investimentos é extremamente importante, tanto para a vida profissional quanto para a pessoal.

Você sente um pouco de insegurança nessa parte? Então, fique tranquilo, porque uma das principais funções do Excel também pode te ajudar com isso. 

Nesse caso, dentro do campo financeiro, podemos encontrar várias funções bacanas, por exemplo, para calcular pagamentos futuros e taxas de juros.  

Fórmulas:

=PGTO ()

=TAXA()

9. Estatísticas

Também precisamos ressaltar as principais funções estatísticas

Dentro dessa categoria, podemos encontrar, por exemplo: mínimo, máximo, média, desvio padrão, variância, entre outras fórmulas. 

Todas elas facilitam bastante o dia a dia de profissionais e estudantes. 

Fórmulas:

=MÍNIMO()

=MÁXIMO()

=MÉDIA ()

=DESVPAD.A()

entre outras. 

10. Matemática

principais-funcoes-do-excel-matematica

Assim como no caso anterior, as funções matemáticas são diversas. Dá para calcular desde uma soma, até mesmo, o cosseno ou o Log de uma equação. 

Profissionais da área de exatas, professores e estudantes encontram muita praticidade nessas funções do Excel. 

Fórmulas:

=SOMARPRODUTO()

=SOMA()

=MULT ou =PRODUTO() [em versões anteriores do Excel]

=LOG()

entre outras. 

11. Contagem

Função contagem ou CONT.SE é usada para você contar determinadas informações dentro das células. 

Isso pode ser referente a números ou textos. Também funciona para caso queira identificar dados errados e problemas. 

Ou seja, é mais uma das principais funções do Excel com aspecto bem versátil. 

Fórmulas:

=CONT.SE()

=CONT.SES()

12. Conversão

Quem nunca precisou converter fórmulas, não é mesmo? 

O bacana é que o Excel também é capaz de fazer as mais variadas adaptações e, claro, tudo com extrema exatidão, sem o risco de você pegar um número errado. 

A função conversão funciona, por exemplo, para transformar metros em quilômetros; gramas em peso; força em joule e vice-versa. 

Esses são só alguns dos exemplos, há ainda muito mais.

Fórmula:

=CONVERTER()

13. Texto

principais-funcoes-excel

Por fim, mas não menos importante, a função texto é ideal para você trocar o modo de exibição de algum valor.

Por exemplo, imagine que as informações sobre a data ficaram assim na sua planilha: 20072021. 

Ao inserir a função texto, é possível organizar isso do seguinte modo: 20/07/2021.

É algo muito útil, sobretudo, para planilhas com um grande número de linhas e/ou colunas, já que a transformação é instantânea. Nada de precisar fazer tudo no manual. 

Fórmula:

=FÓRMULATEXTO()

Observação: as fórmulas que citamos aqui também estão disponíveis na guia Inserir, localizada no menu do Excel. Lá você vai poder visualizá-las em cada uma das categorias para não se perder!

Quer aprender a mexer no Excel ainda hoje? Conheça o Curso Completo Online e com certificação de Excel da Hashtag Treinamentos!

Conclusão 

Viu só como são muitas as principais funções do Excel? 

Agora que você já as conhece, não perca mais tempo. Comece a testar tudo e torne-se um expert no assunto!

Para te ajudar nisso, conte com o curso 100% online de Excel da Hashtag Treinamentos

As aulas foram pensadas e montadas para que qualquer pessoa possa sair do nível atual (básico, intermediário ou avançado) para se tornar um impressionador. 

Tudo para você surpreender seus chefes e outros colegas de trabalho, conquistar sonhos e espaços. 

Aproveite essa oportunidade única e aprenda Excel sem precisar sair de casa!

Aprenda a se destacar na sua empresa apenas com o Excel! Na Jornada do Excel vamos te ensinar a impressionar com as suas planilhas!