Blog

Postado em em 23 de março de 2021

Gráfico de Controle – Impressionando o Chefe

Gráfico de Controle no Excel

Nessa aula nós vamos te mostrar como criar um gráfico de controle no Excel para que você possa impressionar o seu chefe na reunião da empresa!

Caso prefira esse conteúdo no formato de vídeo-aula, assista ao vídeo abaixo ou acesse o nosso canal do YouTube!

Para receber a planilha que usamos na aula no seu e-mail, preencha:

Como Fazer um Gráfico de Controle no Excel

Você já deve ter passado por uma situação em que precisava criar um gráfico de controle para analisar o estoque dos seus produtos.

Hoje nós vamos te mostrar como criar um gráfico de controle para você impressionar seu chefe, colegas de trabalho ou quem for.

Vamos fazer um gráfico com os limites de estoque e vamos deixar ele com uma formatação automática para impressionar!

Bora para o próximo tópico porque a aula de hoje está excelente!

Como Fazer um Gráfico de Estoque no Excel

O nosso objetivo é construir o gráfico abaixo a partir de algumas informações.

Gráfico de Controle
Gráfico de Controle

Esse gráfico de controle vai permitir com que o usuário consiga inserir o limite inferior e superior para a quantidade em estoque, assim vai poder analisar essas quantias fora desses limites.

Então inicialmente teríamos apenas os dados das colunas A e B, mas para criar esse gráfico vamos precisar de mais 4 colunas auxiliares para que possamos fazer alguns cálculos para ter esse resultado.

Gráfico de Controle
Tabela de dados

Vamos utilizar as seguintes fórmulas para as colunas:

  1. =$B$15
  2. =$B$16
  3. =SE(B2>C2;NÃO.DISP();B2)
  4. =SE(B2>D2;B2;NÃO.DISP())

As duas primeiras colunas auxiliares são para que o nosso gráfico fique com uma linha constante no gráfico para mostrar o limite mínimo e limite máximo.

As outras duas fórmulas são para comparar os valores de estoque atual com o valor mínimo e máximo para que no gráfico somente o que está abaixo do mínimo e acima do máximo sejam evidenciados.

Assim teremos uma formatação automática desses dados e deixará o gráfico mais visual e mais fácil de analisar.

Outro ponto importante nessas duas fórmulas é a função NÃO.DISP(), essa função permite com que retorne um “erro” na célula para evitar que essa informação seja representada no gráfico.

Isso é importante para evitar com que o gráfico tenha os marcadores no 0 por exemplo. E com a fórmula SE no Excel é que vamos verificar se temos o resultado ou esse erro.

Com essas colunas criadas, nós já podemos criar o nosso gráfico de linha no Excel para poder fazer nossas análises e alterações.

Após a criação do gráfico vamos fazer algumas formatações básicas para deixar o gráfico mais limpo.

Gráfico de linha
Gráfico de linha

Agora é o momento em que vamos formatar as linhas do gráfico, onde basta selecionar a linha desejada e clicar nela com o botão direito do mouse e selecionar a opção Formatar Série de Dados.

Opção para formatar os dados
Opção para formatar os dados

Com isso temos uma aba sendo aberta ao lado direito do programa para que possamos fazer algumas alterações.

Formatando a linha de estoque
Formatando a linha de estoque

Na parte de linha de preenchimento (balde) vamos alterar a cor da linha, a largura e vamos marcar a opção linha suavizada.

Depois podemos selecionar a linha de mínimo e máximo e formatá-las também.

Formatando o mínimo e máximo no gráfico
Formatando o mínimo e máximo no gráfico

Esse é o gráfico que temos até o momento. Agora na parte superior dessa aba, na seta logo ao lado do nome Opções de Série, vamos selecionar a série do valor mínimo do nosso estoque.

Trocando a seleção para continuar a formatação
Trocando a seleção para continuar a formatação

Logo no início vamos marcar a opção Sem Linha para não mostrar linha e vamos até a opção de Marcador.

Formatando os marcadores
Formatando os marcadores

Aqui vamos poder fazer as formatações dessa coluna, mas aqui vamos inserir um tipo de marcador e vamos editar para melhorar a visualização.

Gráfico de controle
Gráfico com os marcadores formatados

Nosso gráfico já está quase pronto, agora só falta colocarmos o rótulo de dados. Para isso basta selecionar a nossa linha de estoque (preta) e ir até a opção de + ao lado do gráfico e marcar a opção de rótulo de dados.

Gráfico de controle completo
Gráfico de controle completo

Aqui já fizemos a mudança dos limites inferior e superior para que você observe que a nossa marcação é automática, então somente o que está fora desse limite, para baixo ou para cima que será marcado para evidenciar.

Agora você tem um gráfico automático para fazer sua análise de estoque no Excel. É um gráfico que vai impressionar, pois além de mostrar o estoque, você tem os limites que são marcados à medida que um produto está abaixo ou acima dos limites.

Conclusão do Gráfico de Controle

Nessa aula conseguimos aprender a como construir um gráfico de controle para análise de estoque.

Esse gráfico não é simplesmente um gráfico de linha, mas um gráfico completo que mostra tanto um limite inferior quanto um limite superior de estoque.

E caso o estoque do produto esteja fora desses limites ele ficará realçado para visualizar de forma mais fácil que há um problema.

Agora é só praticar o que aprendeu e impressionar o seu chefe com esse super gráfico de controle!

Hashtag Treinamentos

Para acessar outras publicações de Excel Intermediário, clique aqui!


Quer aprender tudo de Excel para se tornar o destaque de qualquer empresa?


Vai começar o maior evento de Power BI da América Latina! Quer participar? Preencha seu e-mail abaixo: