Blog

Postado em em 22 de abril de 2021

SOMASE no Excel – Como Somar com Critério no Excel

Função SOMASE no Excel

Nessa aula vamos te mostrar como utilizar a função SOMASE no Excel para que você possa fazer suas somas com critério e criar seus resumos!

Função SOMASE no Excel

Você já deve ter ouvido falar na função SOMASE certo? Se não ouviu falar, não se preocupe!

Nessa aula nós vamos te mostrar como essa função funciona e como ela vai te ajudar muito na construção e análise dos seus relatórios!

Está curioso para saber como utilizar essa função? Então vamos ao próximo tópico!

Essa é uma das Funções Básicas do Excel que vai juntar a função SOMA com a função SE.

Como Utilizar a Função SOMASE no Excel?

O primeiro passo antes de utilizar essa função é saber qual a estrutura dessa função.

Ela possui 3 argumentos sendo 2 deles obrigatórios, ou seja, um deles é opcional e vai depender do que o usuário está calculando.

Estrutura da função SOMASE
Estrutura da função SOMASE
  • Intervalo – É o intervalo onde vamos fazer a análise de critério (pode ser o intervalo das informações ou já ser o próprio intervalo onde faremos a soma);
  • Critério – É o que será levado em consideração para somar os valores, pode ser nome, valor ou até referência de células;
  • Intervalo Soma – Esse intervalo é opcional, pois caso o primeiro intervalo já seja onde a soma irá ocorrer não será necessário selecioná-lo novamente, caso contrário é aqui onde vamos colocar o intervalo dos valores que serão somados.

Agora que já sabemos como utilizar essa função, nada melhor do que colocar esse conhecimento em prática.

Tabela de dados
Tabela de dados

Aqui temos a nossa tabela com algumas informações e vamos fazer alguns cálculos utilizando a função SOMASE para que você possa verificar algumas aplicações.

Exemplos para utilizar a função SOMASE
Exemplos para utilizar a função SOMASE

Vamos fazer o cálculo para somar a quantidade e o total de dois produtos específicos, vamos somar o total dos produtos que possuem o preço acima de R$8,00 e por fim vamos verificar quanto cada um dos vendedores vendeu no total!

Veja que essa é uma tabela pequena e para fazer isso na mão seria bem fácil, no entanto quando temos uma tabela com mais de 1.000 linhas por exemplo já teríamos um problema para fazer isso.

Então por esse motivo é que essa função é muito útil, pois vai somar independente da quantidade de dados que temos na tabela.

=SOMASE(C5:C26;”Morango”;D5:D26)

=SOMASE(C5:C26;”Morango”;F5:F26)

Vamos utilizar essas duas fórmulas para calcular a quantidade total de morango e o gasto total desse produto.

Veja que a única diferença entre essas duas fórmulas é apenas o intervalo de soma, isso porque o critério e o intervalo de critério são os mesmos, pois estamos analisando o produto.

E baseado no produto queremos somar a quantidade e o preço total, então basta alterar o intervalo da soma de quantidade para total na fórmula.

Para o segundo produto nós vamos fazer exatamente o mesmo procedimento, a única diferença será o critério, que é outro produto.

OBS: Lembrando que quando utilizamos texto dentro de uma fórmula ele precisa estar entre aspas duplas para que o Excel consiga reconhecê-lo como texto.

=SOMASE(C5:C26;”Cebola”;D5:D26)

=SOMASE(C5:C26;”Cebola”;F5:F26)

Como vamos continuar pegando o critério da coluna de produtos e somar quantidade e preço esses intervalos serão mantidos.

Agora vamos para o cálculo dos produtos acima de R$8,00! Esse exemplo é para que você possa verificar como colocamos certos critérios dentro da fórmula.

=SOMASE(E5:E26;”>8″;F5:F26)

Veja que nesse caso não estamos escrevendo e como não temos como fazer uma comparação direta nessa função, nós temos que utilizar esse recurso de colocar o operador + o valor entre aspas duplas.

Dessa forma o Excel vai entender que só vai somar os valores que são maiores do que 8 nessa coluna de preço.

Agora vamos para a segunda parte prática, onde vamos calcular quanto cada vendedor vendeu.

=SOMASE($B$5:$B$26;K5;$F$5:$F$26)

Aqui nós vamos efetuar o trancamento dos intervalos, mas porquê? Isso é necessário porque como vamos “arrastar” a fórmula precisamos que o intervalo fique fixo, pois os dados da tabela são os mesmos.

Então é necessário fixar esses intervalos. Outro ponto interessante é que ao invés de escrever o nome de cada vendedor, estamos utilizando a célula que contém o nome deles como referência, assim fica ainda mais fácil de utilizar a função.

Isso é interessante, pois dessa forma não há necessidade de ficar alterando a função sempre que trocar o nome do vendedor.

Resultado da função SOMASE
Resultado da função SOMASE

Como temos poucos dados na tabela você pode conferir de forma manual para verificar se de fato a soma está correta.

Caso não esteja correta é sempre bom verificar os intervalos que foram selecionados, se toda as linhas da tabela foram selecionadas e se os critérios também estão corretos.

Para o segundo caso é muito importante verificar se foi feito o trancamento dos intervalos, pois ao arrastar a fórmula a referência tanto das células quanto dos intervalos será alterada.

Feita essas verificações sua fórmula vai funcionar perfeitamente e já pode automatizar seus cálculos sem precisar fazer tudo de forma manual.

Conclusão

Nessa aula foi possível aprender como a função SOMASE no Excel funciona e como ela pode te auxiliar a fazer somas para evitar com que faça de forma manual e para acrescentar mais informações nos seus relatórios.

Ela é muito importante, pois permite com que o usuário tenha um resumo dos seus dados sem que precise criar uma tabela dinâmica.

Como nem sempre o usuário quer ou precisa de uma tabela dinâmica, dessa forma pode ter a soma desses dados de forma fácil e rápida.

Lembrando que temos a “evolução” dessa função que é a função SOMASES. A diferença é que essa função permite com que o usuário utilize mais de um critério para fazer sua soma, ou seja, pode refinar ainda mais seu detalhamento.

Ou se preferir pode ver o conteúdo em formato de vídeo!

Agora que você sabe como a função SOMASE funciona é hora de partir para a prática e aplicar esses conhecimentos nos seus relatórios!

Hashtag Treinamentos

Para acessar outras publicações de Excel Intermediário, clique aqui!


Quer aprender tudo de Excel para se tornar o destaque de qualquer empresa?


Vai começar o maior evento de Power BI da América Latina! Quer participar? Preencha seu e-mail abaixo: