Blog

Postado em em 12 de outubro de 2018

PROCV Excel – Como usar a fórmula PROCV?

Aprenda em apenas 5min como usar a fórmula PROCV no Excel de forma definitiva e passo a passo.

Quando usar a fórmula PROCV e pra que serve?

De forma simples: Sempre que você quiser pesquisar uma informação em uma tabela você vai usar a fórmula PROCV (ou a fórmula PROCH, que é a mesma coisa que o PROCV só que na horizontal, vou explicar mais pra frente em detalhes).

É só você reparar na fórmula. PROC vem de Procurar e V de vertical. Então quando você tiver uma tabela na vertical e quiser procurar uma informação você vai usar o PROCV. o H do PROCH vem de horizontal, então quando você tiver uma tabela na horizontal e quiser procurar uma informação você vai usar o PROCH.

Pra saber se sua tabela está na vertical ou na horizontal (caso tenha dúvida) é só você pensar: se eu for adicionar mais 1 item, eu vou adicionar embaixo da tabela (vertical) ou ao lado da tabela (horizontal)?

Repare que pesquisar uma informação não é tirar uma média ou fazer uma soma. A fórmula PROCV vai te permitir procurar uma informação que já está escrita na sua tabela, como o valor que um vendedor vendeu (em uma tabela que diz as vendas de todos os vendedores), o preço de um produto (em uma tabela de preços de produtos) e assim vai. Então seria procurar uma informação única de algum item. Exemplo:

tabela procv

Nessa tabela, se eu quiser descobrir o salário do Gabriel Lira ou o Time da Julia Campos eu vou usar a fórmula PROCV.

Se eu quiser saber o salário total dos flamenguistas ou quantos vascaínos eu tenho você não vai usar o PROCV.

 Como usar o PROCV – O passo a passo

Vamos usar a tabela anterior como referência, com os times e os salários. Digamos que eu queira pesquisar o salário da Julia Campos.

O 1º passo é construir um mini resumo em algum lugar fora da tabela (que é onde você vai usar a fórmula PROCV, como nas células E1 e E2.  (igual na imagem abaixo):

Tabela PROCV 2

Ter o nome Julia Campos fora da tabela vai ser muito importante pra construir o PROCV.

O 2º passo é você pensar como você faria isso “no olho”. Como assim?

Se você for olhar a tabela e descobrir o salário da Julia Campos (sem usar o Excel, olhando mesmo), quanto vai ser?

R$12.000,00

Ok, bem fácil, mas agora pensa qual foi o passo a passo que você fez pra achar esse R$12.000,00.

Primeiro você procurou por Julia Campos na tabela. Repara que você quer saber o salário mas quem você procurou (ou seja, o valor procurado) foi Julia Campos. É como se fosse uma referência.

Depois você foi olhando pra ver qual coluna tinha o salário e achou R$12.000,00. Certo?

Então, é exatamente esse mesmo passo a passo que o PROCV vai fazer. Parece que é complexo no Excel, mas na verdade é bem passo a passo. Vamos lá.

Agora você insere a fórmula PROCV na célula E2, basta digitar:

=PROCV(

aplicação fórmula PROCV

Beleza, agora você precisa passar pro PROCV as informações que ele precisa pra funcionar. Você não precisa decorar isso nem os nomes, você só precisa entender o que é cada uma delas, que são 4: Valor Procurado, Matriz Tabela, Num_indice_coluna e Procurar Intervalo.

Valor Procurado – Lembra quando procuramos o salário da Julia Campos “no olho”. Você procurou primeiro por Julia Campos e depois achou o salário. O valor procurado é Julia Campos nesse caso, ou seja, basta você se perguntar: de quem eu quero descobrir o salário?

A resposta é o seu valor procurado: “Julia Campos”

Agora, você pode passar isso de diversas formas:

  1. escrevendo “Julia Campos” na fórmula
  2. selecionando a célula A4 que tem o texto Julia Campos ou
  3. selecionando a célula E1.

A forma correta é selecionar a célula E1, por 2 motivos:

1 – Se você mudar na célula E1 pra outro nome como Alon Pinheiro, sua fórmula já vai atualizar automaticamente. Então você não vai precisar editar essa fórmula mais, e sempre que você criar uma fórmula tem que pensar em como fazer ela de forma bem automática.

2 – Ela não está na sua base de dados. Você nunca pode selecionar uma célula da base de dados porque a sua base de dados pode ser alterada futuramente. Por isso não selecionamos a célula A4, mas sim a célula E1 para fazer o PROCV.

Depois de selecionar a célula E1, aperte o ; (ponto e vírgula). Obs: se eu Excel ou seu computador estiverem em inglês, pode ser que ao invés de ponto e vírgula você precise apertar , (vírgula). É só olhar naquele texto de sugestão que aparece logo abaixo da fórmula que ele mostra o seu caso.

Até agora, nosso PROCV está assim:

=PROCV(E1;

Matriz Tabela – Matriz tabela é basicamente onde o Excel vai fazer essa procura. Você tem que escrever algo como A1:C7 (ou seja, de qual célula ele começa até qual célula ele vai). Tem 2 condições pra ela funcionar:

  1. O valor que você tá procurando (ou seja, o valor procurado do PROCV) tem que estar na 1ª coluna dessa tabela. Isso significa que vamos começar na coluna A no nosso caso, já que Julia Campos (ou seja, os nomes) está na coluna A.
  2. O valor que você quer como resposta, no nosso caso o salário, tem que estar dentro dessa tabela que você vai selecionar. Então no nosso caso temos que selecionar até pelo menos a coluna C. Repara que você pode selecionar mais colunas à direita, mas não pode selecionar só até a B por exemplo, porque o salário está na coluna C.

Então vai ficar de A até C. Aí nesse caso você pode selecionar a coluna toda (A:C) ou só a tabela (A1:C7) e depois colocar o ; (ponto e vírgula).

Então, com isso o nosso PROCV está assim:

=PROCV(E1;A1:C7;

Tabela PROCV 4

Núm_Índice_Coluna – o número índice coluna é basicamente qual a coluna dessa tabela que você selecionou que você quer como resposta. Só que ao invés de dizer a letra, você vai dizer o número.

Nesse caso é o Salário, que é a 3ª coluna dessa tabela. Então no número índice coluna vou colocar 3 (o número 3 mesmo).

Repare que é o número da coluna da tabela que você selecionou, não é necessariamente do Excel. Por exemplo, se eu tivesse procurando o salário de quem torce pro Palmeiras a minha matriz tabela seria de B1:C7. Nesse caso a coluna C é a 2ª coluna da tabela, porque ela começa na coluna B, então seria o número 2 ao invés do número 3, ok?

Com isso, colocando o ; (ponto e vírgula) no final, até agora estamos com o PROCV no Excel assim:

=PROCV(E1;A1:C7;3;

Procurar_Intervalo – apesar de muitas pessoas acharem que essa informação é opcional eu te aconselho a SEMPRE preencher. Isso vai evitar MUITOS erros.

Esse procurar intervalo diz pro Excel se você está procurando exatamente Julia Campos como está escrito na célula E1 ou se você aceita aproximações (aproximação seria como procurar algo como Giulia Campos).

No nosso caso, estamos procurando exatamente Julia Campos, então você vai colocar o número 0 (que é a mesma coisa que escrever FALSO, já que pro Excel 0 e FALSO é a mesma coisa). Se fosse aceitando aproximações você ia colocar o número 1 (ou então VERDADEIRO).

DICA VALIOSA: na dúvida, sempre coloca 0. Em mais de 99% das vezes o certo a colocar é o 0 no procurar intervalo do PROCV. Eu mostro em outro post o único caso em que você coloca o 1 no final ao invés do 0.

Com isso, fechamos a nossa fórmula assim:

=PROCV(E1;A1:C7;3;0)

outra opção (usando FALSO) seria:

=PROCV(E1;A1:C7;3;FALSO)

núm_indice_coluna procv

Pronto, agora apertando Enter o saindo dessa célula ele vai te dar 12000 como resposta.

Repara que provavelmente ele não vai aparecer R$12.000,00 e sim 12000, isso porque a fórmula não puxa os formatos do Excel. Se você quiser, precisa formatar manualmente essa célula mesmo. Pra fazer isso, seleciona a célula (E2, no caso) e clica no botão de formatação de moeda da Guia Página Inicial (ou Início dependendo da sua versão do Excel).

formatar moeda

Pronto, esse é o passo a passo de como fazer o PROCV no Excel.

Isso funciona pra qualquer versão do Excel, seja Excel 2007, Excel 2010, Excel 2013, Excel 2016 e até Excel 2019.

Para saber sobre o PROCH, acompanhe que vamos enviar outros posts.

Para saber como fazer PROCV com 2 condições, acompanhe que vamos enviar outros posts.


Quer aprender tudo de Excel para se tornar o destaque de qualquer empresa?