Blog

Postado em em 12 de dezembro de 2018

Função SE Excel – Como fazer?

Aprenda como fazer a fórmula ou função SE no Excel com 2 condições

Quando usar a Fórmula SE e para que serve?

De forma bem resumida: sempre que você quiser tratar condições no Excel, você vai usar a função SE. Repare que isso vale se for 1 condição, 2 condições, 3 condições ou mais.

Nesse texto vamos mostrar como fazer uma fórmula SE simples, bem passo a passo. Se você quer saber como fazer a fórmula SE com várias condições, você vai precisar fazer um SE composto, ou “função SE encadeada” como alguns chamam e isso eu ensino nesse outro link aqui.

Como usar a função SE no Excel?

Para aprender a função SE vamos criar um exemplo simples. Imagine que você é o vendedor de uma loja e lá existe a seguinte regra:

“Todos os vendedores que conseguem vender mais de R$10.000 no mês ganham um bônus de R$500 além do seu salário”

Tabela Função SE

O objetivo é preencher, automaticamente, a célula C2 de acordo com o valor da célula B2, de forma que sempre que eu mudar a célula B2 ele já pega o valor certo do Bônus na C2.

O segredo pra fazer a fórmula SE no Excel é pensar como você faria isso “no olho”, porque na prática a fórmula vai “pensar da mesma forma que a gente”. Vou explicar.

Fazendo “no olho” você veria que na célula B2 tem o valor de vendas do João Paulo. Nesse momento você se perguntaria: “O valor de vendas é maior do que 10.000?”

Se a resposta for SIM ou VERDADEIRO, o bônus é de R$500, então você colocaria esse valor na C2. Se a resposta for NÃO ou FALSO, o bônus é de R$0, então você colocaria esse valor na célula C2.

Agora fazendo no Excel, você colocaria a fórmula SE na célula C2. Repara que a fórmula vai mudar o valor da célula (mas não vai mudar a cor! Pra mudar a cor tem que fazer formatação condicional que é um outro tema, pode ver aqui se quiser) tem a seguinte estrutura:

=SE(teste_lógico; valor_se_verdadeiro; valor_se_falso)

Agora vamos entender o que é cada uma dessas informações:

Teste Lógico – É sempre uma comparação. No nosso caso eu quero comparar o valor de vendas da pessoa com o valor de R$10.000. Então tem SEMPRE 3 elementos nessa comparação: 1 – um valor, 2 – um sinal de comparação 3 –  outro valor, ou seja, pro nosso caso:

=SE(B2 > 10000;

teste lógico função se excel

Repare que você nunca pode colocar apenas “> 10000” (você tem que fazer uma comparação completa, com os 3 elementos que falei) e também nunca pode colocar a formatação ali dentro, do tipo R$10.000 (você escreve apenas o número).

Valor_se_verdadeiro – Aqui basta você pensar: “Se essa comparação que eu fiz no teste lógico for verdadeira (no nosso caso, se o valor da célula B2 for realmente maior que 10.000), o que eu quero que apareça na célula? O que eu quero como resposta?

Eu quero descobrir o valor de bônus da pessoa, então o que eu quero que apareça é o valor do bônus pro caso dele ter vendido mais de 10.000. Ou seja, R$500, faz sentido?

Então ficaria:

=SE(B2 > 10000; 500 … ou então … =SE(B2 > 10000; F2 … porque na célula F2 tem o valor de 500.

valor se verdadeiro função se excel

Repare novamente que você não escreve na fórmula o R$, ok?

Valor_se_falso – Esse é o contrário do valor_se_verdadeiro, então basicamente é você pensar: “Se essa comparação que eu fiz no teste lógico for falsa (no nosso caso, se o valor da célula B2 for menor_ou igual_ a 10.000), o que eu quero que apareça na célula?

Ou seja, quanto ela ganha de bônus? R$0, faz sentido?

Então fica:

=SE(B2 > 10000;500;0) … ou então … =SE(B2>10000;F2;F3) … porque na célula F3 temos o valor 0.

valor se falso função se excel

Nesse caso, a resposta que vai aparecer na célula C2 é 500.

Repara que provavelmente ele não vai aparecer R$500 e sim 500, isso porque a fórmula não puxa os formatos do Excel. Se você quiser, precisa formatar manualmente essa célula mesmo. Pra fazer isso, seleciona a célula (C2, no caso) e clica no botão de formatação de moeda da Guia Página Inicial (ou Início dependendo da sua versão do Excel).

formatar como moeda excel